1SUMMARY = "A Python implementation of Google's Encoded Polyline Algorithm Format"
2HOMEPAGE = "https://github.com/frederickjansen/polyline"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=1fb8d1dc685695195bb3c1e48adfef48"
5
6SRC_URI[sha256sum] = "10541e759c5fd51f746ee304e9af94744089a4055b6257b293b3afd1df64e369"
7
8inherit pypi python_setuptools_build_meta ptest
9
10RDEPENDS:${PN} += "python3-six"
11
12BBCLASSEXTEND = "native nativesdk"
13
14SRC_URI += " \
15	file://run-ptest \
16"
17
18RDEPENDS:${PN}-ptest += " \
19    python3-pytest \
20    python3-unittest-automake-output \
21"
22
23do_install_ptest() {
24	install -d ${D}${PTEST_PATH}/test
25	cp -rf ${S}/tests/* ${D}${PTEST_PATH}/test/
26}
27