1SUMMARY = "Physical quantities module"
2DESCRIPTION = "Physical quantities Python module"
3HOMEPAGE = "https://github.com/hgrecco/pint"
4SECTION = "devel/python"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
8
9PYPI_PACKAGE := "Pint"
10
11inherit ptest python_setuptools_build_meta
12
13SRCREV = "f2e4081aee38f850938048beac7fb69c4908bc5e"
14SRC_URI = "git://github.com/hgrecco/pint;protocol=https;branch=master"
15S = "${WORKDIR}/git"
16#SRC_URI[sha256sum] = "e1509b91606dbc52527c600a4ef74ffac12fff70688aff20e9072409346ec9b4"
17
18DEPENDS += "python3-setuptools-scm-native"
19
20BBCLASSEXTEND = "native nativesdk"
21
22SRC_URI += " \
23	file://run-ptest \
24"
25
26RDEPENDS:${PN} += " \
27    python3-setuptools \
28    python3-packaging \
29"
30
31RDEPENDS:${PN}-ptest += " \
32	python3-appdirs \
33	python3-flexcache \
34	python3-flexparser \
35	python3-pytest \
36"
37
38do_install_ptest() {
39	install -d ${D}${PTEST_PATH}/testsuite
40	cp -rf ${S}/pint/* ${D}${PTEST_PATH}/
41}
42