1DESCRIPTION = "A pure Python 2/3 library for peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) in Linux."
2HOMEPAGE = "http://pythonhosted.org/python-periphery/"
3LICENSE = "MIT"
4
5LIC_FILES_CHKSUM = "file://LICENSE;md5=30fe6f023a80fb33989fb3b9d773fea0"
6
7SRC_URI[sha256sum] = "61d461d736982a6f766e878720ab10a68151e2e8c1086600d9389ac47e40e88a"
8
9inherit pypi setuptools3
10
11PYPI_PACKAGE = "python-periphery"
12
13RDEPENDS:${PN} += "python3-mmap \
14		python3-ctypes \
15		python3-fcntl"
16