1SUMMARY = "comprehensive password hashing framework supporting over 30 schemes"
2DESCRIPTION = "\
3Passlib is a password hashing library for Python 2 & 3, which provides cross-platform \
4implementations of over 30 password hashing algorithms, as well as a framework for \
5managing existing password hashes. It’s designed to be useful for a wide range of \
6tasks, from verifying a hash found in /etc/shadow, to providing full-strength password \
7hashing for multi-user applications."
8HOMEPAGE = "https://foss.heptapod.net/python-libs/passlib/wikis/home"
9LICENSE = "BSD-3-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=c8449c5e10474d113ab787ed2753bafe"
11
12SRC_URI[md5sum] = "3a229cbd00dfb33e99885b43325e0591"
13SRC_URI[sha256sum] = "defd50f72b65c5402ab2c573830a6978e5f202ad0d984793c8dde2c4152ebe04"
14
15inherit pypi setuptools3
16
17RDEPENDS_${PN} += "\
18    ${PYTHON_PN}-crypt \
19    ${PYTHON_PN}-logging \
20    ${PYTHON_PN}-netclient \
21"
22