1SUMMARY  = "pandas library for high-performance data analysis tools"
2DESCRIPTION = "pandas is an open source, BSD-licensed library providing \
3high-performance, easy-to-use data structures and data analysis tools for \
4the Python programming language."
5HOMEPAGE = "http://pandas.pydata.org/"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=cb819092901ddb13a7d0a4f5e05f098a"
8
9SRC_URI[sha256sum] = "c02f372a88e0d17f36d3093a644c73cfc1788e876a7c4bcb4020a77512e2043c"
10
11inherit pypi setuptools3
12
13DEPENDS += " \
14    python3-cython-native \
15    python3-numpy-native \
16    python3-versioneer-native \
17"
18
19PACKAGESPLITFUNCS =+ "fix_cythonized_sources"
20
21fix_cythonized_sources() {
22	for f in `grep -l -r -e '\/* Generated by Cython.*/$' ${PKGD}${TARGET_DBGSRC_DIR}`; do
23		if [ -e $f ]; then
24			sed -i -e 's#${RECIPE_SYSROOT_NATIVE}##g' $f
25		fi
26	done
27}
28
29CFLAGS:append:toolchain-clang = " -Wno-error=deprecated-declarations"
30
31RDEPENDS:${PN} += " \
32    python3-json \
33    python3-numpy \
34    python3-dateutil \
35    python3-dateutil-zoneinfo \
36    python3-pytz \
37    python3-profile \
38"
39