1SUMMARY = "MessagePack (de)serializer"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://COPYING;md5=cd9523181d9d4fbf7ffca52eaa2a5751"
4
5inherit pypi setuptools3 ptest
6
7SRC_URI[sha256sum] = "572efc93db7a4d27e404501975ca6d2d9775705c2d922390d878fcf768d92c87"
8
9RDEPENDS:${PN}:class-target += "\
10    python3-io \
11"
12
13BBCLASSEXTEND = "native nativesdk"
14
15SRC_URI += " \
16	file://run-ptest \
17"
18
19RDEPENDS:${PN}-ptest += " \
20	python3-pytest \
21	python3-unittest-automake-output \
22"
23
24do_install_ptest() {
25	install -d ${D}${PTEST_PATH}/test
26	cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
27}
28