1# This recipe is adapted from one in meta-jupyter:
2# https://github.com/Xilinx/meta-jupyter/blob/master/recipes-python/python3-mpmath_0.19.bb
3
4SUMMARY = "Python library for arbitrary-precision floating-point arithmetic"
5HOMEPAGE = "https://pypi.org/project/mpmath/"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=bde3c575382996b75d85702949512751"
8
9SRC_URI[sha256sum] = "7a28eb2a9774d00c7bc92411c19a89209d5da7c4c9a9e227be8330a23a25b91f"
10
11inherit pypi setuptools3
12
13DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
14RDEPENDS:${PN} += " \
15    python3-image \
16    python3-math \
17"
18
19BBCLASSEXTEND = "native nativesdk"
20