1SUMMARY = "moteus brushless controller library and tools"
2HOMEPAGE = "https://github.com/mjbots/moteus"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://setup.py;beginline=3;endline=9;md5=24025d3c660abfc62a83f0e709a45e76"
5
6inherit pypi setuptools3
7
8SRC_URI += "file://0001-lib-python-remove-self-import-from-setup.py.patch"
9
10SRC_URI[sha256sum] = "a2122f20f59b8962057cf8d3fb583e0aa19006eaf2cde49e30027a4d1b8bf925"
11
12S = "${WORKDIR}/moteus-${PV}"
13
14RDEPENDS:${PN} += "\
15    python3-can \
16    python3-importlib-metadata \
17    python3-pyelftools \
18    python3-pyserial \
19"
20