1DESCRIPTION = "Generator for random text that looks like Latin"
2HOMEPAGE = "https://github.com/sfischer13/python-lorem"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5301c01b2bcdeedba23645f94db2f179"
5SRC_URI[md5sum] = "e3f0064a94c13e19780eb724affdb426"
6SRC_URI[sha256sum] = "785f4109a241fc2891e59705e85d065f6e6d3ed6ad91750a8cb54d4f3e59d934"
7
8SRC_URI += "\
9        file://run-ptest \
10"
11
12PYPI_PACKAGE = "lorem"
13
14inherit pypi setuptools3 ptest
15
16CLEANBROKEN = "1"
17
18RDEPENDS:${PN} += " \
19        python3 \
20"
21RDEPENDS:${PN}-ptest += " \
22        ${PYTHON_PN}-pytest \
23        ${PYTHON_PN}-unittest-automake-output \
24"
25
26do_install_ptest() {
27    install -d ${D}${PTEST_PATH}/tests
28    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
29}
30