1# This recipe is originally from meta-openstack:
2# https://git.yoctoproject.org/cgit/cgit.cgi/meta-cloud-services/tree/meta-openstack/recipes-devtools/python/python-lockfile_0.12.2.bb
3
4SUMMARY = "Platform-independent file locking module"
5HOMEPAGE = "https://pypi.org/project/lockfile/"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=2340dffbbfea534b58f1349984eeef72"
8
9SRC_URI[sha256sum] = "6aed02de03cba24efabcd600b30540140634fc06cfa603822d508d5361e9f799"
10
11inherit pypi setuptools3
12
13DEPENDS += "python3-distutils-extra-native python3-pbr-native"
14RDEPENDS:${PN} += " \
15    python3-io \
16    python3-sqlite3 \
17"
18
19BBCLASSEXTEND = "native nativesdk"
20