1SUMMARY = "Self-contained ISO 3166-1 country definitions"
2HOMEPAGE = "https://pypi.org/project/iso3166/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5e2f4edc7e7408a82e4a1d05f229b695"
5
6SRC_URI[sha256sum] = "fcd551b8dda66b44e9f9e6d6bbbee3a1145a22447c0a556e5d0fb1ad1e491719"
7
8inherit pypi python_setuptools_build_meta ptest
9
10SRC_URI += " \
11	file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15    python3-pytest \
16    python3-unittest-automake-output \
17"
18
19do_install_ptest() {
20	install -d ${D}${PTEST_PATH}/tests
21	cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
23
24RDEPENDS:${PN} += "python3-numbers"
25
26BBCLASSEXTEND = "native nativesdk"
27