1SUMMARY = "IPython: Productive Interactive Computing"
2HOMEPAGE = "https://ipython.org"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING.rst;md5=59b20262b8663cdd094005bddf47af5f"
5
6PYPI_PACKAGE = "ipython"
7
8SRC_URI[sha256sum] = "2dcaad9049f9056f1fef63514f176c7d41f930daa78d05b82a176202818f2c14"
9
10RDEPENDS:${PN} = "\
11    python3-setuptools \
12    python3-jedi \
13    python3-decorator \
14    python3-pickleshare \
15    python3-traitlets \
16    python3-prompt-toolkit \
17    python3-pygments \
18    python3-backcall \
19    python3-pydoc \
20    python3-debugger \
21    python3-pexpect \
22    python3-unixadmin \
23    python3-misc \
24    python3-sqlite3 \
25    python3-stack-data \
26"
27
28inherit setuptools3 pypi
29