1SUMMARY = "An adapter to Linux kernel support for inotify directory-watching."
2HOMEPAGE = "https://pypi.org/project/inotify/"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://setup.py;md5=79b7ec72aa0d446a552d3cceb5799e41;beginline=28;endline=28"
5
6SRC_URI[sha256sum] = "974a623a338482b62e16d4eb705fb863ed33ec178680fc3e96ccdf0df6c02a07"
7
8SRC_URI = " \
9    git://github.com/dsoprea/pyinotify.git;branch=master;protocol=https \
10    file://new-test-inotify.patch \
11    file://run-ptest \
12"
13
14SRCREV = "9be6a51d1660991562eefaaddefa757ca0e0e00f"
15
16S = "${WORKDIR}/git"
17
18inherit setuptools3 ptest
19
20RDEPENDS:${PN} += " \
21    python3-ctypes \
22    python3-logging \
23"
24
25RDEPENDS:${PN}-ptest += " \
26    python3-pytest \
27    python3-unittest-automake-output \
28"
29
30do_install_ptest() {
31    install -d ${D}${PTEST_PATH}/tests
32    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
33}
34