1SUMMARY = "A port of Ruby on Rails' inflection to Python."
2HOMEPAGE = "https://pypi.org/project/inflection"
3LICENSE = "MIT"
4SECTION = "devel/python"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=2fb6fa1a6f1792d78de19ad1bb653c31"
6
7SRC_URI[md5sum] = "c3287d4f0e3bdf625a52d655cc514403"
8SRC_URI[sha256sum] = "1a29730d366e996aaacffb2f1f1cb9593dc38e2ddd30c91250c6dde09ea9b417"
9
10inherit pypi setuptools3 ptest
11
12SRC_URI +=" \
13	file://run-ptest \
14"
15
16RDEPENDS:${PN}_ptest +=" \
17	${PYTHON_PN}_pytest \
18"
19
20do_install_ptest() {
21	cp -f ${S}/test_inflection.py ${D}${PTEST_PATH}/
22}
23
24
25RDEPENDS:${PN} += "${PYTHON_PN}-pytest"
26
27BBCLASSEXTEND = "native nativesdk"
28