1DESCRIPTION = "Incremental is a small library that versions your Python projects"
2HOMEPAGE = "https://github.com/twisted/incremental"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=6ca9b07f08e2c72d48c74d363d1e0e15"
5
6SRC_URI[sha256sum] = "fb4f1d47ee60efe87d4f6f0ebb5f70b9760db2b2574c59c8e8912be4ebd464c9"
7
8inherit pypi python_setuptools_build_meta
9
10PACKAGE_BEFORE_PN = "\
11    ${PN}-scripts \
12    ${PN}-tests \
13"
14
15FILES:${PN}-scripts = "\
16    ${PYTHON_SITEPACKAGES_DIR}/incremental/update.py \
17    ${PYTHON_SITEPACKAGES_DIR}/incremental/__pycache__/update*.pyc \
18"
19
20RDEPENDS:${PN}-scripts = "\
21    python3-click \
22"
23
24FILES:${PN}-tests = "${PYTHON_SITEPACKAGES_DIR}/incremental/tests"
25
26# The tests require unit testing tool 'trial' from the twisted package
27RDEPENDS:${PN}-tests = "\
28    ${PN}-scripts \
29    python3-twisted \
30"
31
32BBCLASSEXTEND = "native"
33
34