1DESCRIPTION = "Incremental is a small library that versions your Python projects"
2HOMEPAGE = "https://github.com/twisted/incremental"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=6ca9b07f08e2c72d48c74d363d1e0e15"
5
6SRC_URI[sha256sum] = "912feeb5e0f7e0188e6f42241d2f450002e11bbc0937c65865045854c24c0bd0"
7
8inherit pypi setuptools3
9
10RDEPENDS:${PN} += " \
11    ${PYTHON_PN}-twisted \
12    ${PYTHON_PN}-click \
13"
14
15# -native is needed to build python[3]-twisted, however, we need to take steps to
16# prevent a circular dependency. The build apparently does not use the part of
17# python-incremental which uses python-twisted, so this hack is OK.
18RDEPENDS:${PYTHON_PN}-incremental-native:remove = "${PYTHON_PN}-twisted-native"
19BBCLASSEXTEND = "native"
20