1SUMMARY = "Python extension wrapping the ICU C++ API"
2HOMEPAGE = "https://gitlab.pyicu.org/main/pyicu"
3BUGTRACKER = "https://gitlab.pyicu.org/main/pyicu/-/issues"
4SECTION = "devel/python"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=0724597863f1581ab01429e0423e779f"
7
8DEPENDS += "icu"
9
10PYPI_PACKAGE = "PyICU"
11
12SRC_URI[sha256sum] = "d4919085eaa07da12bade8ee721e7bbf7ade0151ca0f82946a26c8f4b98cdceb"
13
14SRC_URI += "file://0001-Fix-host-contamination-of-include-files.patch"
15
16inherit pkgconfig pypi python_setuptools_build_meta
17
18# it's lowercase pyicu instead of ${PYPI_PACKAGE} in this version
19S = "${WORKDIR}/pyicu-${PV}"
20