1SUMMARY = "A next generation HTTP client for Python."
2SECTION = "devel/python"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.md;md5=c624803bdf6fc1c4ce39f5ae11d7bd05"
5
6inherit pypi python_hatchling
7
8SRC_URI[sha256sum] = "a0cb88a46f32dc874e04ee956e4c2764aba2aa228f650b06788ba6bda2962ab5"
9
10DEPENDS += "\
11    python3-hatch-fancy-pypi-readme-native \
12"
13
14PACKAGECONFIG ??= ""
15PACKAGECONFIG[brotli] = ",,,python3-brotli"
16PACKAGECONFIG[http2] = ",,,python3-h2"
17PACKAGECONFIG[socks] = ",,,python3-socksio"
18
19RDEPENDS:${PN} += "\
20    python3-anyio \
21    python3-certifi \
22    python3-httpcore \
23    python3-idna \
24    python3-sniffio \
25    python3-json \
26    python3-core \
27    python3-netclient \
28    python3-compression \
29"
30
31PACKAGES += "\
32    ${PN}-cli \
33"
34
35RDEPENDS:${PN}-cli += "\
36    ${PN} \
37    python3-click \
38    python3-pygments \
39    python3-rich \
40"
41
42FILES:${PN} = "\
43    ${libdir}/${PYTHON_DIR} \
44"
45
46FILES:${PN}-cli = "\
47    ${bindir}/httpx \
48"
49