1SUMMARY = "A collection of framework independent HTTP protocol utils."
2HOMEPAGE = "https://github.com/MagicStack/httptools"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=0a2d82955bf3facdf04cb882655e840e"
5
6inherit pypi setuptools3 ptest
7
8SRC_URI[sha256sum] = "c6e26c30455600b95d94b1b836085138e82f177351454ee841c148f93a9bad5a"
9
10SRC_URI += " \
11        file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15        python3-pytest \
16        python3-unittest-automake-output \
17"
18
19do_install_ptest() {
20        install -d ${D}${PTEST_PATH}/tests
21        cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
23