1SUMMARY = "WSGI HTTP Server for UNIX"
2
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5b70a8b30792a916f50dc96123e61ddf"
5
6SRC_URI[sha256sum] = "f014447a0101dc57e294f6c18ca6b40227a4c90e9bdb586042628030cba004ec"
7
8inherit pypi python_setuptools_build_meta ptest
9
10SRC_URI += " \
11	file://run-ptest \
12"
13
14# python-misc for wsgiref
15RDEPENDS:${PN}-ptest += " \
16    python3-eventlet \
17    python3-gevent \
18    python3-misc \
19    python3-pytest \
20    python3-unittest-automake-output \
21"
22
23do_install_ptest() {
24	install -d ${D}${PTEST_PATH}/tests
25	cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
27
28RDEPENDS:${PN} += "python3-setuptools python3-fcntl"
29