1SUMMARY = "A coroutine-based Python networking library"
2DESCRIPTION = "gevent is a coroutine-based Python networking library that uses greenlet to provide \
3a high-level synchronous API on top of the libevent event loop."
4HOMEPAGE = "http://www.gevent.org"
5LICENSE = "MIT & Python-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65"
7DEPENDS += "python3-greenlet libev libuv c-ares python3-cython-native"
8
9RDEPENDS:${PN} = "python3-greenlet \
10		  python3-mime \
11		  python3-pprint \
12		  python3-zopeevent \
13		  python3-zopeinterface \
14		 "
15
16SRC_URI += "file://0001-_setuputils.py-Do-not-add-sys_inc_dir.patch \
17	        file://not-final.patch"
18
19SRC_URI[sha256sum] = "432fc76f680acf7cf188c2ee0f5d3ab73b63c1f03114c7cd8a34cebbe5aa2056"
20
21inherit pypi setuptools3
22
23# Don't embed libraries, link to the system provided libs instead
24export GEVENTSETUP_EMBED_CARES = "0"
25export GEVENTSETUP_EMBED_LIBEV = "0"
26export GEVENTSETUP_EMBED_LIBUV = "0"
27
28do_configure:append() {
29	# Delete the embedded copies of libraries so we can't accidentally link to them
30	rm -rf ${S}/deps
31
32	# Delete the generated cython files, as they are all out of date with python 3.11
33	rm -rf ${S}/src/gevent/*.c
34}
35
36do_compile:append() {
37        sed -i -e 's#${WORKDIR}##g' ${S}/src/gevent/*.c ${S}/src/gevent/libev/*.c ${S}/src/gevent/resolver/*.c
38}
39