1SUMMARY = "A coroutine-based Python networking library"
2DESCRIPTION = "gevent is a coroutine-based Python networking library that uses greenlet to provide \
3a high-level synchronous API on top of the libevent event loop."
4HOMEPAGE = "http://www.gevent.org"
5LICENSE = "MIT & Python-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65"
7DEPENDS += "python3-greenlet-native python3-greenlet libev libuv python3-cffi-native"
8
9RDEPENDS:${PN} = "python3-greenlet \
10		  python3-mime \
11		  python3-pprint \
12		  python3-zopeevent \
13		  python3-zopeinterface \
14		 "
15
16SRC_URI += "file://0001-_setuputils.py-Do-not-add-sys_inc_dir.patch \
17	        file://not-final.patch"
18
19SRC_URI[sha256sum] = "432fc76f680acf7cf188c2ee0f5d3ab73b63c1f03114c7cd8a34cebbe5aa2056"
20
21inherit pypi python_setuptools_build_meta cython
22
23# Don't embed libraries, link to the system provided libs instead
24export GEVENTSETUP_EMBED_CARES = "0"
25export GEVENTSETUP_EMBED_LIBEV = "0"
26export GEVENTSETUP_EMBED_LIBUV = "0"
27
28do_configure:append() {
29	# Delete the embedded copies of libraries so we can't accidentally link to them
30	rm -rf ${S}/deps
31
32	# Delete the generated cython files, as they are all out of date with python 3.11
33	rm -rf ${S}/src/gevent/*.c
34}
35
36# http://errors.yoctoproject.org/Errors/Details/766918/
37# src/gevent/queue.c:11894:83: error: passing argument 1 of '__pyx_vtabptr_6gevent_14_gevent_cqueue_UnboundQueue->__pyx_base.put' from incompatible pointer type [-Wincompatible-pointer-types]
38# src/gevent/queue.c:11894:114: error: passing argument 4 of '__pyx_vtabptr_6gevent_14_gevent_cqueue_UnboundQueue->__pyx_base.put' from incompatible pointer type [-Wincompatible-pointer-types]
39CFLAGS += "-Wno-error=incompatible-pointer-types"
40