1SUMMARY = "Python bindings and utilities for GeoJSON"
2HOMEPAGE = "https://pypi.org/project/geojson/"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=f77f2ed49768c8d4c79ba874c0f94d8a"
5
6SRC_URI[sha256sum] = "58a7fa40727ea058efc28b0e9ff0099eadf6d0965e04690830208d3ef571adac"
7
8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11	file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15    python3-pytest \
16    python3-unittest-automake-output \
17"
18
19do_install_ptest() {
20	install -d ${D}${PTEST_PATH}/tests
21	cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
23
24RDEPENDS:${PN} += "python3-simplejson python3-math"
25
26BBCLASSEXTEND = "native nativesdk"
27