1DESCRIPTION = "generate GCC code coverage reports"
2HOMEPAGE = "https://gcovr.com"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c5a58ca91c1758a53f896ba89d8aaac2"
6
7SRC_URI = "git://github.com/gcovr/gcovr.git;branch=main;protocol=https"
8SRCREV = "c4b74b0859611283be646d590c7915e787911b6f"
9
10S = "${WORKDIR}/git"
11
12inherit setuptools3
13
14RDEPENDS:${PN} += "python3-jinja2 python3-lxml python3-setuptools python3-pygments python3-multiprocessing"
15
16BBCLASSEXTEND = "native nativesdk"
17