1SUMMARY = "Saves and loads to the cache a transformed versions of a source object."
2HOMEPAGE = "https://github.com/hgrecco/flexcache"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=32f547dac365c355d2cdbcd7ebea9144"
5DEPENDS += "python3-setuptools-scm-native"
6SRC_URI[sha256sum] = "18743bd5a0621bfe2cf8d519e4c3bfdf57a269c15d1ced3fb4b64e0ff4600656"
7
8inherit pypi python_setuptools_build_meta ptest
9PYPI_PACKAGE = "flexcache"
10
11SRC_URI += " \
12        file://run-ptest \
13"
14
15RDEPENDS:${PN}-ptest += " \
16        python3-pytest \
17        python3-unittest-automake-output \
18"
19
20do_install_ptest() {
21        install -d ${D}${PTEST_PATH}/testsuite
22        cp -rf ${S}/flexcache/testsuite/* ${D}${PTEST_PATH}/testsuite/
23}
24
25RDEPENDS:${PN} += " \
26	python3-compression \
27	python3-email \
28	python3-json \
29	python3-pickle \
30	python3-typing-extensions \
31"
32