1# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Fastest Python implementation of JSON schema"
5HOMEPAGE = "https://github.com/seznam/python-fastjsonschema"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=18950e8362b69c0c617b42b8bd8e7532"
8
9SRCREV = "756540088687cda351390f687b92e602feaa7dc6"
10PYPI_SRC_URI = "git://github.com/horejsek/python-fastjsonschema;protocol=https;branch=master"
11
12SRC_URI += "file://run-ptest"
13
14inherit ptest pypi setuptools3
15
16S = "${WORKDIR}/git"
17
18do_install_ptest() {
19	install -d ${D}${PTEST_PATH}/tests
20	cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
21}
22
23RDEPENDS:${PN}-ptest += "\
24    python3-colorama \
25    python3-jsonschema \
26    python3-pylint \
27    python3-pytest \
28    python3-pytest-benchmark \
29    python3-pytest-cache \
30    python3-unittest-automake-output \
31"
32RDEPENDS:${PN} += "\
33    python3-core \
34    python3-urllib3 \
35    python3-numbers \
36    python3-pickle \
37    python3-json \
38    "
39
40BBCLASSEXTEND = "native nativesdk"
41