1# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "execnet: rapid multi-Python deployment"
5HOMEPAGE = "https://execnet.readthedocs.io/en/latest/"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=772fcdaca14b378878d05c7d857e6c3e"
8
9DEPENDS += "\
10    python3-pip-native \
11    python3-hatch-vcs-native \
12"
13
14SRC_URI += "file://run-ptest \
15           "
16SRC_URI[sha256sum] = "cc59bc4423742fd71ad227122eb0dd44db51efb3dc4095b45ac9a08c770096af"
17
18inherit ptest pypi python_hatchling
19
20do_install_ptest() {
21    install -d ${D}${PTEST_PATH}/tests
22    cp -rf ${S}/testing/* ${D}${PTEST_PATH}/tests/
23}
24
25RDEPENDS:${PN}-ptest += "\
26    python3-pytest \
27    python3-unittest-automake-output \
28"
29
30RDEPENDS:${PN} += "python3-core python3-crypt python3-ctypes python3-fcntl python3-io python3-shell python3-threading"
31
32BBCLASSEXTEND = "native nativesdk"
33