1SUMMARY = "Dominate is a Python library for creating and manipulating HTML documents using an elegant DOM API."
2LICENSE = "LGPL-3.0-only"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b52f2d57d10c4f7ee67a7eb9615d5d24"
4
5SRC_URI[sha256sum] = "558284687d9b8aae1904e3d6051ad132dd4a8c0cf551b37ea4e7e42a31d19dc4"
6
7inherit pypi ptest python_setuptools_build_meta
8
9SRC_URI += " \
10	file://run-ptest \
11"
12
13RDEPENDS:${PN}-ptest += " \
14    python3-pytest \
15    python3-unittest-automake-output \
16"
17
18do_install_ptest() {
19	install -d ${D}${PTEST_PATH}/tests
20	cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
21}
22
23RDEPENDS:${PN} += "\
24    python3-numbers \
25    python3-threading \
26    "
27