1SUMMARY = "A python package implementing the crc32c algorithmin hardware and software"
2HOMEPAGE = "https://github.com/ICRAR/crc32c"
3
4LICENSE = "BSD-2-Clause & BSD-3-Clause & CRC32C-ADLER & LGPL-2.0-or-later"
5LIC_FILES_CHKSUM = " \
6    file://LICENSE;md5=4fbd65380cdd255951079008b364516c \
7    file://LICENSE.google-crc32c;md5=e9ed01b5e5ac9eae23fc2bb33701220c \
8    file://LICENSE.slice-by-8;md5=6b3bc7709d6b2db6646ec2467310ff6b \
9    file://crc32c_adler.c;beginline=9;endline=24;md5=9c8bd2afd2d340fd37c038759cd4eff8 \
10"
11
12SRC_URI[sha256sum] = "17ce6c596ad0d53df52dcd72defb66984aeabd98fbefea7ba848a6b6bdece36a"
13
14inherit pypi setuptools3
15
16do_compile:prepend() {
17    if ! grep 'platform =' setup.cfg; then
18        printf "[build_ext]\nplatform = ${TARGET_ARCH}" >> setup.cfg
19    fi
20}
21
22RDEPENDS:${PN} += "python3-core"
23