1SUMMARY = "Controller Area Network (CAN) interface module for Python"
2HOMEPAGE = "https://github.com/hardbyte/python-can"
3SECTION = "devel/python"
4LICENSE = "LGPL-3.0-only"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e6a600fd5e1d9cbde2d983680233ad02"
6
7SRC_URI[sha256sum] = "1c46c0935f39f7a9c3e76b03249af0580689ebf7a1844195e92f87257f009df5"
8
9PYPI_PACKAGE = "python_can"
10
11inherit pypi python_setuptools_build_meta
12
13RDEPENDS:${PN} += "\
14    python3-aenum \
15    python3-asyncio \
16    python3-codecs \
17    python3-compression \
18    python3-ctypes \
19    python3-fcntl \
20    python3-json \
21    python3-logging \
22    python3-misc \
23    python3-netserver \
24    python3-packaging \
25    python3-pkg-resources \
26    python3-setuptools \
27    python3-sqlite3 \
28    python3-typing-extensions \
29    python3-wrapt \
30"
31