1SUMMARY = "Controller Area Network (CAN) interface module for Python"
2SECTION = "devel/python"
3LICENSE = "LGPL-3.0-only"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e6a600fd5e1d9cbde2d983680233ad02"
5
6SRC_URI[sha256sum] = "6ad50f4613289f3c4d276b6d2ac8901d776dcb929994cce93f55a69e858c595f"
7
8PYPI_PACKAGE="python-can"
9
10inherit pypi setuptools3
11
12RDEPENDS:${PN} += " \
13    python3-aenum \
14    python3-asyncio \
15    python3-codecs \
16    python3-compression \
17    python3-ctypes \
18    python3-fcntl \
19    python3-json \
20    python3-logging \
21    python3-misc \
22    python3-netserver \
23    python3-pkg-resources \
24    python3-sqlite3 \
25    python3-typing-extensions \
26    python3-wrapt \
27"
28
29BBCLASSEXTEND = "native nativesdk"
30