1# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "An aspect-oriented programming, monkey-patch and decorators library."
5DESCRIPTION = " It is useful when changing behavior in existing code is desired. \
6It includes tools for debugging and testing: simple mock/record and a complete capture/replay framework."
7HOMEPAGE = "https://github.com/ionelmc/python-aspectlib"
8LICENSE = "BSD-2-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=80721ace117fd1f814049ecb81c6be76"
10
11SRC_URI[sha256sum] = "a4b461b9da0b531aebcb93efcde3de808a72c60226dd8d902c467d13faf7ce92"
12
13inherit ptest pypi setuptools3
14
15SRC_URI += "file://run-ptest \
16           "
17
18do_install_ptest() {
19    install -d ${D}${PTEST_PATH}/tests
20    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
21}
22
23RDEPENDS:${PN}-ptest += "\
24    python3-process-tests \
25    python3-pytest \
26    python3-tornado \
27    python3-unittest-automake-output \
28"
29
30RDEPENDS:${PN} += "python3-core python3-fields"
31
32BBCLASSEXTEND = "native nativesdk"
33