1SUMMARY = "Meta-python ptest packagegroups"
2
3inherit packagegroup
4
5PROVIDES = "${PACKAGES}"
6PACKAGES = ' \
7    packagegroup-meta-python3 \
8'
9
10# Note that python3-cvxopt requires Fortran support. To enable this,
11# add the following to your local.conf:
12# FORTRAN:forcevariable = ",fortran"
13RDEPENDS:packagegroup-meta-python3 = "\
14    ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "python3-systemd", "", d)} \
15    ${@bb.utils.contains("DISTRO_FEATURES", "x11 systemd", "python3-blivetgui", "", d)} \
16    gyp \
17    ${@bb.utils.contains("DISTRO_FEATURES", "pam", "pamela", "", d)} \
18    pyrtm \
19    python3-absl \
20    python3-aenum \
21    python3-aiofiles \
22    python3-aiohttp \
23    python3-aiohttp-jinja2 \
24    python3-aiohue \
25    python3-aiosignal \
26    python3-alembic \
27    python3-ansi2html \
28    python3-ansicolors \
29    python3-appdirs \
30    python3-apply-defaults \
31    python3-argcomplete \
32    python3-argexec \
33    python3-argh \
34    python3-arpeggio \
35    python3-asciitree \
36    python3-aspectlib \
37    python3-astor \
38    python3-astroid \
39    python3-asttokens \
40    python3-async-timeout \
41    python3-asyncio-glib \
42    python3-attr \
43    python3-autobahn \
44    python3-automat \
45    python3-aws-iot-device-sdk-python \
46    python3-backcall \
47    python3-bandit \
48    python3-beautifulsoup4 \
49    python3-behave \
50    python3-betamax \
51    python3-bitarray \
52    python3-bitstring \
53    python3-bitstruct \
54    python3-blinker \
55    ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "python3-blivet", "", d)} \
56    python3-booleanpy \
57    python3-cachecontrol \
58    python3-cached-property \
59    python3-cachetools \
60    python3-can \
61    python3-cantools \
62    python3-cassandra-driver \
63    python3-cbor2 \
64    python3-cerberus \
65    python3-chardet \
66    python3-charset-normalizer \
67    python3-cheetah \
68    python3-click \
69    python3-click-repl \
70    python3-click-spinner \
71    python3-cmd2 \
72    python3-colorama \
73    python3-coloredlogs \
74    python3-colorlog \
75    python3-colorzero \
76    python3-configargparse \
77    python3-configobj \
78    python3-configshell-fb \
79    python3-constantly \
80    python3-contextlib2 \
81    python3-coverage \
82    python3-cppy \
83    python3-crcmod \
84    python3-croniter \
85    python3-cson \
86    python3-custom-inherit \
87    ${@bb.utils.contains_any('FORTRAN', [',fortran',',f77'], 'python3-cvxopt', '', d)} \
88    python3-cycler \
89    python3-cytoolz \
90    python3-dateparser \
91    python3-dateutil \
92    python3-dbus-next \
93    python3-dbussy \
94    python3-decorator \
95    python3-decouple \
96    python3-defusedxml \
97    python3-dill \
98    python3-diskcache \
99    python3-distro \
100    python3-django \
101    python3-django-south \
102    python3-djangorestframework \
103    python3-dnspython \
104    python3-docopt \
105    python3-docutils \
106    python3-dominate \
107    python3-dynamic-dispatch \
108    python3-ecdsa \
109    python3-editables \
110    python3-editor \
111    python3-email-validator \
112    python3-engineio \
113    python3-et-xmlfile \
114    python3-eth-abi \
115    python3-eth-account \
116    python3-eth-hash \
117    python3-eth-keyfile \
118    python3-eth-keys \
119    python3-eth-rlp \
120    python3-eth-typing \
121    python3-eth-utils \
122    python3-evdev \
123    python3-execnet \
124    python3-fann2 \
125    python3-fasteners \
126    python3-fastjsonschema \
127    python3-fastnumbers \
128    python3-fields \
129    python3-flask \
130    python3-flask-babel \
131    python3-flask-bootstrap \
132    python3-flask-jsonpify \
133    python3-flask-jwt \
134    python3-flask-login \
135    python3-flask-mail \
136    python3-flask-migrate \
137    python3-flask-nav \
138    python3-flask-pymongo \
139    python3-flask-restful \
140    python3-flask-sijax \
141    python3-flask-socketio \
142    python3-flask-sqlalchemy \
143    python3-flask-uploads \
144    python3-flask-user \
145    python3-flask-versioned \
146    python3-flask-wtf \
147    python3-flask-xstatic \
148    python3-future \
149    python3-frozenlist \
150    python3-gast \
151    python3-gcovr \
152    python3-geojson \
153    python3-geomet \
154    python3-gevent \
155    python3-gmpy2 \
156    python3-gmqtt \
157    python3-gnupg \
158    python3-google-api-python-client \
159    python3-gpiod \
160    python3-gpsd-py3 \
161    python3-graphviz \
162    python3-greenlet \
163    python3-greenstalk \
164    python3-grpcio \
165    python3-grpcio-tools \
166    python3-gsocketpool \
167    python3-gunicorn \
168    python3-h11 \
169    python3-h2 \
170    python3-h5py \
171    python3-hatchling \
172    python3-haversine \
173    python3-hpack \
174    python3-html2text \
175    python3-html5lib \
176    python3-httplib2 \
177    python3-huey \
178    python3-humanfriendly \
179    python3-humanize \
180    python3-hyperframe \
181    python3-hyperlink \
182    python3-icu \
183    python3-idna \
184    python3-idna \
185    python3-idna-ssl \
186    python3-ifaddr \
187    python3-imageio \
188    python3-imgtool \
189    python3-incremental \
190    python3-inflection \
191    python3-inotify \
192    python3-intelhex \
193    python3-intervals \
194    python3-ipaddress \
195    python3-ipy \
196    python3-ipython \
197    python3-ipython-genutils \
198    python3-iso3166 \
199    python3-isodate \
200    python3-isort \
201    python3-itsdangerous \
202    python3-javaobj-py3 \
203    python3-jdatetime \
204    python3-jdcal \
205    python3-jedi \
206    python3-jmespath \
207    python3-joblib \
208    python3-jsmin \
209    python3-jsonpatch \
210    python3-jsonpath-rw \
211    python3-jsonpointer \
212    python3-jsonref \
213    python3-jsonschema \
214    python3-jstyleson \
215    python3-kconfiglib \
216    python3-keras-applications \
217    python3-keras-preprocessing \
218    ${@bb.utils.contains("DISTRO_FEATURES", "x11 opengl", "python3-kivy", "", d)} \
219    python3-kiwisolver \
220    python3-langtable \
221    python3-lazy-object-proxy \
222    python3-libconf \
223    python3-license-expression \
224    python3-ldap \
225    python3-lockfile \
226    python3-lorem \
227    python3-lrparsing \
228    python3-lru-dict \
229    python3-luma-core \
230    python3-luma-oled \
231    python3-lxml \
232    python3-lz4 \
233    python3-m2crypto \
234    python3-markupsafe \
235    python3-matplotlib \
236    python3-mccabe \
237    python3-meh \
238    python3-meld3 \
239    python3-mock \
240    python3-monotonic \
241    python3-mpmath \
242    python3-msgpack \
243    python3-msk \
244    python3-msm \
245    python3-multidict \
246    python3-mypy \
247    python3-mypy-extensions \
248    python3-natsort \
249    python3-netaddr \
250    python3-netifaces \
251    python3-networkx \
252    python3-nmap \
253    python3-nocasedict \
254    python3-nocaselist \
255    python3-ntplib \
256    python3-oauthlib \
257    python3-obd \
258    python3-openpyxl \
259    python3-ordered-set \
260    python3-padaos \
261    python3-padatious \
262    python3-paho-mqtt \
263    python3-pako \
264    python3-pandas \
265    python3-parallax \
266    python3-paramiko \
267    python3-parse \
268    python3-parse-type \
269    python3-parsimonious \
270    python3-parso \
271    python3-passlib \
272    python3-pastedeploy \
273    python3-pathspec \
274    python3-pathtools3 \
275    python3-pep8 \
276    python3-periphery \
277    python3-petact \
278    python3-pexpect \
279    python3-pickleshare \
280    python3-pid \
281    python3-pika \
282    python3-pillow \
283    python3-pint \
284    python3-pkcs11 \
285    python3-pkgconfig \
286    python3-pocketsphinx \
287    python3-polyline \
288    python3-portalocker \
289    python3-posix-ipc \
290    python3-prctl \
291    python3-precise-runner \
292    python3-prettytable \
293    python3-priority \
294    python3-process-tests \
295    python3-progress \
296    python3-prompt-toolkit \
297    python3-protobuf \
298    python3-ptyprocess \
299    python3-pulsectl \
300    python3-py-cpuinfo \
301    python3-py-ubjson \
302    python3-pyalsaaudio \
303    python3-pyasn1-modules \
304    python3-pyatspi \
305    python3-pyaudio \
306    python3-pybind11 \
307    python3-pybind11-json \
308    python3-pybluez \
309    python3-pychromecast \
310    python3-pycocotools \
311    python3-pycodestyle \
312    python3-pyconnman \
313    python3-pycurl \
314    python3-pydbus \
315    python3-pydicti \
316    python3-pyephem \
317    python3-pyexpect \
318    python3-pyfanotify \
319    python3-pyfirmata \
320    python3-pyflakes \
321    python3-pyhamcrest \
322    python3-pyiface \
323    python3-pyjks \
324    python3-pyjwt \
325    python3-pykickstart \
326    python3-pykwalify \
327    python3-pylint \
328    python3-pylyrics \
329    python3-pymetno \
330    python3-pymisp \
331    python3-pymongo \
332    python3-pymysql \
333    python3-pynacl \
334    python3-pynetlinux \
335    python3-pyparted \
336    python3-pyperclip \
337    python3-pyperf \
338    python3-pyrad \
339    python3-pyro4 \
340    python3-pyroute2 \
341    python3-pyrsistent \
342    python3-pyscaffold \
343    python3-pyserial \
344    python3-pysonos \
345    ${@bb.utils.contains("DISTRO_FEATURES", "systemd", "python3-pystemd", "", d)} \
346    python3-pytest-asyncio \
347    python3-pytest-benchmark \
348    python3-pytest-cache \
349    python3-pytest-forked \
350    python3-pytest-helpers-namespace \
351    python3-pytest-html \
352    python3-pytest-lazy-fixtures \
353    python3-pytest-metadata \
354    python3-pytest-tempdir \
355    python3-pytest-timeout \
356    python3-pytest-xdist \
357    python3-pythonping \
358    python3-python-vlc \
359    python3-pytoml \
360    python3-pytun \
361    python3-pyudev \
362    python3-pyusb \
363    python3-pywbem \
364    python3-pywbemtools \
365    python3-pyyaml \
366    python3-pyzmq \
367    python3-qrcode \
368    python3-raven \
369    python3-rdflib \
370    python3-redis \
371    python3-regex \
372    python3-requests-file \
373    python3-requests-ftp \
374    python3-requests-futures \
375    python3-requests-oauthlib \
376    python3-requests-toolbelt \
377    python3-rfc3339-validator \
378    python3-rfc3986-validator \
379    python3-rfc3987 \
380    python3-rlp \
381    python3-robotframework \
382    python3-robotframework-seriallibrary \
383    python3-rsa \
384    python3-ruamel-yaml \
385    python3-scrypt \
386    python3-sdnotify \
387    python3-semver \
388    python3-send2trash \
389    python3-sentry-sdk \
390    python3-serpent \
391    python3-service-identity \
392    python3-setuptools-declarative-requirements \
393    python3-sh \
394    python3-sijax \
395    python3-simpleeval \
396    python3-simplejson \
397    python3-slip-dbus \
398    python3-smbus \
399    python3-smbus2 \
400    python3-smpplib \
401    python3-snappy \
402    python3-socketio \
403    python3-soupsieve \
404    python3-speaklater \
405    python3-speedtest-cli \
406    python3-spidev \
407    python3-spidev \
408    python3-sqlalchemy \
409    python3-sqlparse \
410    python3-sqlsoup \
411    python3-stevedore \
412    python3-supervisor \
413    python3-sympy \
414    python3-tabulate \
415    python3-term \
416    python3-termcolor \
417    python3-textparser \
418    python3-texttable \
419    python3-thrift \
420    python3-tinyrecord \
421    python3-tornado \
422    python3-toolz \
423    python3-tqdm \
424    python3-trafaret \
425    python3-trafaret-config \
426    python3-traitlets \
427    python3-transitions \
428    python3-trustme \
429    python3-twine \
430    python3-twisted \
431    python3-twitter \
432    python3-twofish \
433    python3-txaio \
434    python3-txdbus \
435    python3-txws \
436    python3-typeguard \
437    python3-tzlocal \
438    python3-u-msgpack-python \
439    python3-ujson \
440    python3-unidiff \
441    python3-uritemplate \
442    python3-vcversioner \
443    python3-versioneer \
444    python3-versiontools \
445    python3-visitor \
446    python3-waitress \
447    python3-watchdog \
448    python3-watchdogdev \
449    python3-web3 \
450    python3-webcolors \
451    python3-webencodings \
452    python3-websocket-client \
453    python3-websockets \
454    python3-werkzeug \
455    python3-werkzeug \
456    python3-whoosh \
457    python3-wrapt \
458    python3-wtforms \
459    python3-xlrd \
460    python3-xlsxwriter \
461    python3-xmltodict \
462    python3-xmodem \
463    python3-xstatic \
464    python3-xstatic-font-awesome \
465    python3-xxhash \
466    python3-yamlloader \
467    python3-yappi \
468    python3-yarl \
469    python3-zopeinterface \
470    telepathy-python3 \
471    unattended-upgrades \
472"
473
474RDEPENDS:packagegroup-meta-python3-ptest = "\
475    python3-ansicolors-ptest \
476    python3-appdirs-ptest \
477    python3-betamax-ptest \
478    python3-blinker-ptest \
479    python3-cachetools-ptest \
480    python3-cbor2-ptest \
481    python3-click-ptest \
482    python3-dnspython-ptest \
483    python3-dominate-ptest \
484    python3-geojson-ptest \
485    python3-gunicorn-ptest \
486    python3-hexbytes \
487    python3-html2text-ptest \
488    python3-inflection-ptest \
489    python3-intervals-ptest \
490    python3-ipy-ptest \
491    python3-iso3166-ptest \
492    python3-jdcal-ptest \
493    python3-jinja2-ptest \
494    python3-jsmin-ptest \
495    python3-jsonpointer-ptest \
496    python3-license-expression-ptest \
497    python3-markupsafe-ptest \
498    python3-msgpack-ptest \
499    python3-multidict-ptest \
500    python3-ordered-set-ptest \
501    python3-parse-ptest \
502    python3-parse-type-ptest \
503    python3-pint-ptest \
504    python3-polyline-ptest \
505    python3-precise-runner-ptest \
506    python3-prettytable-ptest \
507    python3-ptyprocess-ptest \
508    python3-pyasn1-modules-ptest \
509    python3-pyroute2-ptest \
510    python3-pyserial-ptest \
511    python3-pytoml-ptest \
512    python3-pyzmq-ptest \
513    python3-requests-file-ptest \
514    python3-requests-toolbelt-ptest \
515    python3-scrypt-ptest \
516    python3-semver-ptest \
517    python3-serpent-ptest \
518    python3-simpleeval-ptest \
519    python3-smpplib-ptest \
520    python3-soupsieve-ptest \
521    python3-sqlparse-ptest \
522    python3-typeguard-ptest \
523    python3-ujson-ptest \
524    python3-u-msgpack-python-ptest \
525    python3-unidiff-ptest \
526    python3-uritemplate-ptest \
527    python3-webcolors-ptest \
528    python3-whoosh-ptest \
529    python3-wpa-supplicant \
530    python3-xlrd-ptest \
531    python3-xmltodict-ptest \
532    python3-xxhash-ptest \
533    python3-yappi-ptest \
534    python3-yarl-ptest \
535    python3-pyasn1-ptest \
536"
537
538EXCLUDE_FROM_WORLD = "1"
539