1SUMMARY = "Python bindings for the Apache Thrift RPC system"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
4
5SRC_URI[sha256sum] = "4dd662eadf6b8aebe8a41729527bd69adf6ceaa2a8681cbef64d1273b3e8feba"
6
7inherit pypi setuptools3
8
9# Use different filename to prevent conflicts with thrift itself
10PYPI_SRC_URI:append = ";downloadfilename=${BP}.${PYPI_PACKAGE_EXT}"
11
12RDEPENDS:${PN} += "\
13    python3-logging \
14    python3-scons \
15    python3-six \
16    python3-stringold \
17    python3-threading \
18"
19
20BBCLASSEXTEND = "native"
21