1SUMMARY = "Perl interface to the libxml2 library"
2DESCRIPTION = "This module is an interface to libxml2, providing XML and HTML parsers \
3with DOM, SAX and XMLReader interfaces, a large subset of DOM Layer 3 \
4interface and a XML::XPath-like interface to XPath API of libxml2. \
5The module is split into several packages which are not described in this \
6section; unless stated otherwise, you only need to use XML::LibXML; in \
7your programs."
8
9HOMEPAGE = "http://search.cpan.org/dist/XML-LibXML-1.99/"
10SECTION = "libs"
11LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
12DEPENDS += "libxml2 \
13        libxml-sax-perl-native \
14        zlib \
15"
16RDEPENDS:${PN} += "\
17    libxml2 \
18    libxml-sax-perl \
19    libxml-sax-base-perl \
20    perl-module-encode \
21    perl-module-data-dumper \
22    zlib \
23"
24
25SRC_URI = "http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/XML-LibXML-${PV}.tar.gz;name=libxml \
26    file://disable-libxml2-check.patch \
27    file://fix-CATALOG-conditional-compile.patch \
28    file://using-DOCB-conditional.patch \
29    file://0001-libxml-mm-Fix-function-prototypes-in-function-pointe.patch \
30"
31LIC_FILES_CHKSUM = "file://debian/copyright;md5=64eda1bc135f0ece1d1187f2a8ac82c1 \
32    file://LICENSE;md5=97871bde150daeb5e61ad95137ff2446 \
33"
34SRC_URI[libxml.md5sum] = "dce687dd8b7e82d1c359fd74b1852f64"
35SRC_URI[libxml.sha256sum] = "f0bca4d0c2da35d879fee4cd13f352014186cedab27ab5e191f39b5d7d4f46cf"
36
37S = "${WORKDIR}/XML-LibXML-${PV}"
38
39inherit cpan ptest-perl
40
41EXTRA_CPANFLAGS = "INC=-I${STAGING_INCDIR}/libxml2 LIBS=-L${STAGING_LIBDIR}"
42
43BBCLASSEXTEND = "native"
44
45CFLAGS += " -D_GNU_SOURCE "
46BUILD_CFLAGS += " -D_GNU_SOURCE "
47
48FILES:${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/XML/LibXML/.debug/"
49
50RDEPENDS:${PN}-ptest += " \
51    liburi-perl \
52    perl-module-encode-byte \
53    perl-module-encode-unicode \
54    perl-module-locale \
55    perl-module-perlio-scalar \
56    perl-module-test-more \
57"
58
59do_install:prepend() {
60	# test requires "-T" (taint) command line option
61	rm -rf ${B}/t/pod.t
62	# this only applies to author build
63	rm -rf ${B}/t/pod-files-presence.t
64}
65
66do_install_ptest() {
67	cp -r ${B}/t/data ${D}${PTEST_PATH}/t/
68	cp -r ${B}/t/lib ${D}${PTEST_PATH}/t/
69	cp -r ${B}/example ${D}${PTEST_PATH}
70	cp -r ${B}/test ${D}${PTEST_PATH}
71	chown -R root:root ${D}${PTEST_PATH}
72}
73