1SUMMARY = "Test::Deep - Extremely flexible deep comparison"
2DESCRIPTION = "If you don't know anything about automated testing in Perl \
3then you should probably read about Test::Simple and Test::More before \
4preceding. Test::Deep uses the Test::Builder framework. \
5\
6Test::Deep gives you very flexible ways to check that the result you got is \
7the result you were expecting. At its simplest it compares two structures \
8by going through each level, ensuring that the values match, that arrays and \
9hashes have the same elements and that references are blessed into the \
10correct class. It also handles circular data structures without getting \
11caught in an infinite loop. \
12\
13Where it becomes more interesting is in allowing you to do something besides \
14simple exact comparisons. With strings, the \'eq\' operator checks that 2 \
15strings are exactly equal but sometimes that's not what you want. When you \
16don't know exactly what the string should be but you do know some things \
17about how it should look, \'eq\' is no good and you must use pattern matching \
18instead. Test::Deep provides pattern matching for complex data structures \
19distribution."
20
21SECTION = "libs"
22
23HOMEPAGE = "http://github.com/rjbs/Test-Deep/"
24
25LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
26LIC_FILES_CHKSUM = "file://lib/Test/Deep.pm;beginline=1817;endline=1826;md5=d3ed382cc19bae8ead6076df35a43cbf"
27
28SRC_URI = "${CPAN_MIRROR}/authors/id/R/RJ/RJBS/Test-Deep-${PV}.tar.gz"
29SRC_URI[sha256sum] = "b6591f6ccdd853c7efc9ff3c5756370403211cffe46047f082b1cd1611a84e5f"
30
31UPSTREAM_CHECK_REGEX = "Test\-Deep\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
32
33S = "${WORKDIR}/Test-Deep-${PV}"
34
35inherit cpan ptest-perl
36
37RDEPENDS:${PN} += " \
38    perl-module-dynaloader \
39    perl-module-exporter \
40    perl-module-fcntl \
41    perl-module-list-util \
42    perl-module-scalar-util \
43    perl-module-strict \
44    perl-module-vars \
45    perl-module-warnings \
46"
47
48RDEPENDS:${PN}-ptest += " \
49    perl-module-if \
50    perl-module-lib \
51    perl-module-test-more \
52    perl-module-test-tester \
53"
54
55BBCLASSEXTEND = "native"
56