1SUMMARY = "Net::SSLeay - Perl extension for using OpenSSL"
2DESCRIPTION = "This module offers some high level convenience functions for accessing \
3web pages on SSL servers (for symmetry, same API is offered for \
4accessing http servers, too), a sslcat() function for writing your own \
5clients, and finally access to the SSL api of SSLeay/OpenSSL package \
6so you can write servers or clients for more complicated applications."
7HOMEPAGE = "http://search.cpan.org/dist/Net-SSLeay/"
8SECTION = "libs"
9
10LICENSE = "Artistic-1.0 | GPL-1.0+"
11LIC_FILES_CHKSUM = "file://README;beginline=274;endline=294;md5=67d67095d83e339da538a082fad5f38e"
12
13DEPENDS = "openssl zlib openssl-native"
14RDEPENDS:${PN} += "\
15    libssl \
16    libcrypto \
17    perl-module-carp \
18    perl-module-errno \
19    perl-module-extutils-makemaker \
20    perl-module-mime-base64 \
21    perl-module-socket \
22    perl-module-autoloader \
23    zlib \
24"
25
26SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MI/MIKEM/Net-SSLeay-${PV}.tar.gz \
27           file://no-exec-on-configure.patch \
28           file://run-ptest \
29          "
30SRC_URI[md5sum] = "d602bdce4e0531c6efc276e3e429ca69"
31SRC_URI[sha256sum] = "9d8188b9fb1cae3bd791979c20554925d5e94a138d00414f1a6814549927b0c8"
32
33S = "${WORKDIR}/Net-SSLeay-${PV}"
34
35inherit cpan ptest
36
37do_configure() {
38    export OPENSSL_PREFIX="${STAGING_EXECPREFIXDIR}"
39    cpan_do_configure
40}
41
42do_install_ptest() {
43    cp -r ${B}/t ${D}${PTEST_PATH}
44}
45
46FILES:${PN}-dbg =+ "${libdir}/perl/vendor_perl/*/auto/Net/SSLeay/.debug/"
47
48RDEPENDS:${PN}-ptest = " perl"
49