1SUMMARY = "Automatically give your module the ability to have plugins"
2DESCRIPTION = "Provides a simple but, hopefully, extensible way of \
3having 'plugins' for your module. Obviously this isn't going to be the \
4be all and end all of solutions but it works for me.\
5\
6Essentially all it does is export a method into your namespace that \
7looks through a search path for .pm files and turn those into class \
8names.\
9\
10Optionally it instantiates those classes for you."
11SECTION = "libs"
12
13HOMEPAGE = "https://github.com/simonwistow/Module-Pluggable"
14
15LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
16LIC_FILES_CHKSUM = "file://README;beginline=322;endline=325;md5=086450ce010f6fda25db0b38fcc41086"
17
18SRCNAME = "Module-Pluggable"
19SRC_URI = "${CPAN_MIRROR}/authors/id/S/SI/SIMONW/${SRCNAME}-${PV}.tar.gz"
20SRC_URI[md5sum] = "87ce2971662efd0b69a81bb4dc9ea76c"
21SRC_URI[sha256sum] = "b3f2ad45e4fd10b3fb90d912d78d8b795ab295480db56dc64e86b9fa75c5a6df"
22
23PR = "r1"
24
25UPSTREAM_CHECK_REGEX = "Module\-Pluggable\-(?P<pver>(\d+\.\d+))"
26UPSTREAM_CHECK_URI = "https://metacpan.org/release/${SRCNAME}"
27
28S = "${WORKDIR}/${SRCNAME}-${PV}"
29
30inherit cpan
31
32RDEPENDS:${PN} = " perl-module-base \
33    perl-module-deprecate \
34    perl-module-file-basename \
35    perl-module-file-find \
36    perl-module-file-spec \
37    perl-module-file-spec-functions \
38    perl-module-if \
39    perl-module-test-more \
40"
41
42BBCLASSEXTEND = "native"
43
44