1SUMMARY = "IO-stringy - I/O on in-core objects like strings and arrays"
2DESCRIPTION = "This toolkit primarily provides modules for performing both \
3traditional and object-oriented i/o on things *other* than normal \
4filehandles; in particular, IO::Scalar, IO::ScalarArray, and IO::Lines."
5
6HOMEPAGE = "http://www.zeegee.com/products/IO-stringy/"
7SECTION = "devel"
8LICENSE = "Artistic-1.0 | GPL-1.0+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=01406e4ff2e60d88d42ef1caebdd0011"
10
11
12SRC_URI = "${CPAN_MIRROR}/authors/id/D/DS/DSKOLL/IO-stringy-${PV}.tar.gz"
13SRC_URI[md5sum] = "e91acf0a800b190d13585a47de775bdd"
14SRC_URI[sha256sum] = "8c67fd6608c3c4e74f7324f1404a856c331dbf48d9deda6aaa8296ea41bf199d"
15
16S = "${WORKDIR}/IO-stringy-${PV}"
17
18inherit cpan
19
20RPROVIDES:${PN} += " libio-atomicfile-perl \
21    libio-innerfile-perl \
22    libio-lines-perl \
23    libio-scalar-perl \
24    libio-scalararray-perl \
25    libio-wrap-perl \
26    libio-wraptie-perl \
27    libio-wraptie-master-perl \
28    libio-wraptie-slave-perl \
29"
30
31BBCLASSEXTEND = "native"
32