1SUMMARY = "HTML::TreeBuilder - Parser that builds a HTML syntax tree"
2DESCRIPTION = "This distribution contains a suite of modules for representing, \
3creating, and extracting information from HTML syntax trees; there is \
4also relevent documentation.  These modules used to be part of the \
5libwww-perl distribution, but are now unbundled in order to facilitate \
6a separate development track."
7SECTION = "libs"
8
9HOMEPAGE = "http://www.cpan.org/authors/id/C/CJ/CJM/HTML-Tree-${PV}.readme"
10
11LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=3eb57a8958cae73cb65e7d0c26339242"
13
14SRC_URI = "${CPAN_MIRROR}/authors/id/C/CJ/CJM/HTML-Tree-${PV}.tar.gz \
15           file://bin-htmltree-fix-shebang.patch \
16"
17SRC_URI[md5sum] = "d9271d60b872ed6fbe68b2d0fe8c450e"
18SRC_URI[sha256sum] = "7d6d73fca622aa74855a8b088faa39454a0f91b7af83c9ec0387f01eefc2148f"
19
20S = "${WORKDIR}/HTML-Tree-${PV}"
21
22inherit cpan_build
23
24export PERL_USE_UNSAFE_INC = "1"
25
26DEPENDS += "libmodule-build-perl-native \
27"
28
29RPROVIDES:${PN} = " libhtml-element-perl \
30    libhtml-tree-assubs-perl \
31    libhtml-tree-perl \
32    libhtml-treebuilder-perl \
33"
34
35RDEPENDS:${PN} = " perl-module-b \
36    perl-module-base \
37    perl-module-strict \
38    perl-module-warnings \
39    perl-module-exporter \
40    perl-module-carp \
41"
42
43BBCLASSEXTEND = "native"
44
45