1SUMMARY = "Low-Level Interface to bzip2 compression library"
2DESCRIPTION = ""Compress::Raw::Bzip2" provides an interface to the in-memory \
3compression/uncompression functions from the bzip2 compression library."
4HOMEPAGE = "https://metacpan.org/release/Compress-Raw-Bzip2"
5SECTION = "libs"
6LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
7
8LIC_FILES_CHKSUM = "file://README;beginline=8;endline=10;md5=85ab0f65a47c4c0f72dd6d033ff74ece"
9
10SRC_URI = "${CPAN_MIRROR}/authors/id/P/PM/PMQS/Compress-Raw-Bzip2-${PV}.tar.gz"
11
12SRC_URI[sha256sum] = "212b81db1c0ae822d19928619a603bd108cb5d5c4700fc67dc7cb169e0cc6525"
13
14DEPENDS += "bzip2"
15
16S = "${WORKDIR}/Compress-Raw-Bzip2-${PV}"
17
18inherit cpan
19
20export BUILD_BZIP2="0"
21export BZIP2_INCLUDE="-I${STAGING_DIR_HOST}${includedir}"
22
23do_compile() {
24	export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
25	cpan_do_compile
26}
27
28BBCLASSEXTEND = "native"
29