1SUMMARY = "Construct and optionally mail MIME messages"
2DESCRIPTION = "Constructs and (by default) mails MIME messages. \
3               It is entirely driven from the command line, it is \
4               designed to be used by other programs, or people who act \
5               like programs."
6HOMEPAGE = "http://search.cpan.org/~rosch/mime-construct/mime-construct"
7SECTION = "mail"
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://debian/copyright;md5=5e2e5da619ac8ef8c84767ccc4656e96"
10
11SRC_URI = "${CPAN_MIRROR}/authors/id/R/RO/ROSCH/mime-construct-${PV}.tar.gz \
12    file://fix-mime-construct-help-return-value.patch \
13"
14
15SRC_URI[md5sum] = "73834ea780fbea81b89dbd9b2fb54f58"
16SRC_URI[sha256sum] = "4cd7bb61b51d41192d1498c1051aa6a4ccd75aeb09b71d2ec706a7084a4a9303"
17
18inherit cpan
19
20RDEPENDS_${PN} += "libmime-types-perl libproc-waitstat-perl msmtp \
21    perl-module-filehandle perl-module-mime-base64 perl-module-mime-quotedprint perl-module-posix \
22"
23
24do_install_append() {
25   #change the interpreter in file
26   sed -i -e "s|${STAGING_BINDIR_NATIVE}/perl-native/perl -w|${bindir}/env perl|g" \
27      ${D}/${bindir}/mime-construct
28}
29