1SUMMARY = "Analyzes log files and sends noticeable events as email"
2DESCRIPTION = "\
3Logcheck is a simple utility which is designed to allow a system administrator \
4to view the log-files which are produced upon hosts under their control. \
5It does this by mailing summaries of the log-files to them, after first \
6filtering out "normal" entries. \
7Normal entries are entries which match one of the many included regular \
8expression files contain in the database."
9SECTION = "Applications/System"
10HOMEPAGE = "http://logcheck.org/"
11LICENSE = "GPL-2.0-only"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=c93c0550bd3173f4504b2cbd8991e50b"
13
14SRC_URI = "${DEBIAN_MIRROR}/main/l/${BPN}/${BPN}_${PV}.tar.xz \
15           file://99_logcheck \
16"
17SRC_URI[sha256sum] = "ad83ae80bd780bdae5eefd40ad59a3e97b85ad3a4962aa7c00d98ed3bdffcdd0"
18
19inherit useradd
20
21USERADD_PACKAGES = "${PN}"
22USERADD_PARAM:${PN} = "-m -g ${BPN} -G adm -r -d ${localstatedir}/lib/${BPN} \
23                       -s /bin/false -c 'logcheck account' ${BPN}"
24GROUPADD_PARAM:${PN} = "-r ${BPN}"
25
26do_install() {
27    # Fix QA Issue
28    sed -i '/install -d $(DESTDIR)\/var\/lock\/logcheck/s/^/#/' Makefile
29
30    # "make install" do not install the manpages. Install them manually.
31    install -m 755 -d ${D}${mandir}/man1
32    install -m 755 -d ${D}${mandir}/man8
33    install -m 644 docs/logcheck-test.1 ${D}${mandir}/man1/
34    install -m 644 docs/logtail.8 ${D}${mandir}/man8/
35    install -m 644 docs/logtail2.8 ${D}${mandir}/man8/
36
37    install -m 755 -d ${D}${sysconfdir}/cron.d
38    install -m 644 debian/logcheck.cron.d ${D}${sysconfdir}/cron.d/logcheck
39    install -m 755 -d ${D}/var/lib/logcheck
40
41    oe_runmake install DESTDIR=${D}
42
43    # install header.txt for generated mails
44    install -m 0644 ${S}/debian/header.txt ${D}${sysconfdir}/${BPN}
45
46    chown -R ${BPN}:${BPN} ${D}${localstatedir}/lib/${BPN}
47    chown -R root:${BPN} ${D}${sysconfdir}/${BPN}
48
49    # Don't install /var/lock when populating rootfs. Do it through volatile
50    if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
51        install -d ${D}${sysconfdir}/default/volatiles
52        install -m 0644 ${WORKDIR}/99_logcheck ${D}${sysconfdir}/default/volatiles
53    fi
54    if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
55        install -d ${D}${sysconfdir}/tmpfiles.d
56        echo "d /var/lock/logcheck 0755 logcheck logcheck -" \
57            > ${D}${sysconfdir}/tmpfiles.d/logcheck.conf
58    fi
59}
60
61VIRTUAL-RUNTIME_syslog ??= "rsyslog"
62
63RDEPENDS:${PN} = "\
64    bash \
65    cronie \
66    debianutils-run-parts \
67    grep \
68    lockfile-progs \
69    mime-construct \
70    perl \
71    perl-module-file-basename \
72    perl-module-getopt-std \
73    perl-module-file-glob \
74    ${VIRTUAL-RUNTIME_syslog} \
75"
76
77FILES:${PN} += "${datadir}/logtail"
78