1DESCRIPTION = "CxxTest is a unit testing framework for C++ that is similar in spirit to JUnit, CppUnit, and xUnit."
2HOMEPAGE = "http://cxxtest.com/"
3SECTION = "devel"
4LICENSE = "LGPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
6
7SRC_URI = "http://downloads.sourceforge.net/project/cxxtest/cxxtest/${PV}/${BP}.tar.gz"
8SRC_URI[md5sum] = "c3cc3355e2ac64e34c215f28e44cfcec"
9SRC_URI[sha256sum] = "1c154fef91c65dbf1cd4519af7ade70a61d85a923b6e0c0b007dc7f4895cf7d8"
10
11inherit setuptools3
12
13PIP_INSTALL_DIST_PATH = "${B}/python/python3/dist"
14
15SETUPTOOLS_SETUP_PATH = "${S}/python"
16
17do_install:append() {
18    install -d ${D}${includedir}
19    cp -a ${S}/cxxtest/ ${D}${includedir}
20    # Fix the interpretter as otherwise this points to the build host python
21    sed '1c\
22#!/usr/bin/env python3' -i ${D}${bindir}/cxxtestgen
23}
24
25BBCLASSEXTEND = "native nativesdk"
26