1SUMMARY = "Bash Automated Testing System"
2DESCRIPTION = "Bats is a TAP-compliant testing framework for Bash. It \
3provides a simple way to verify that the UNIX programs you write behave as expected."
4HOMEPAGE = "https://github.com/bats-core/bats-core"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b"
7
8SRC_URI = "\
9  git://github.com/bats-core/bats-core.git;branch=master;protocol=https \
10  "
11
12# v1.10.0
13SRCREV = "7531b575bb81487553553aecb654c41b237ae96c"
14
15S = "${WORKDIR}/git"
16
17# Numerous scripts assume ${baselib} == lib, which is not true.
18#
19do_configure:prepend() {
20	for f in ${S}/libexec/bats-core/* ${S}/lib/bats-core/* ; do
21		sed -i 's:\$BATS_ROOT/lib/:\$BATS_ROOT/${baselib}/:g' $f
22	done
23}
24
25do_install() {
26	# Just a bunch of bash scripts to install
27	${S}/install.sh ${D}${prefix} ${baselib}
28}
29
30RDEPENDS:${PN} = "bash"
31FILES:${PN} += "${libdir}/bats-core/*"
32
33PACKAGECONFIG ??= "pretty"
34PACKAGECONFIG[pretty] = ",,,ncurses"
35