1SUMMARY = "yaml-cpp parser and emitter library"
2DESCRIPTION = "yaml-cpp is a YAML parser and emitter in C++ matching the YAML 1.2 spec."
3HOMEPAGE = "https://github.com/jbeder/yaml-cpp"
4SECTION = "devel"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=6a8aaf0595c2efc1a9c2e0913e9c1a2c"
7
8# yaml-cpp releases are stored as archive files in github.
9# download the exact revision of release
10SRC_URI = "git://github.com/jbeder/yaml-cpp.git;branch=master;protocol=https"
11SRCREV = "f7320141120f720aecc4c32be25586e7da9eb978"
12
13S = "${WORKDIR}/git"
14
15inherit cmake
16
17EXTRA_OECMAKE = "-DYAML_CPP_BUILD_TESTS=OFF -DYAML_BUILD_SHARED_LIBS=ON -DYAML_CPP_BUILD_TOOLS=OFF"
18