1SUMMARY = "USB hub per-port power control"
2HOMEPAGE = "https://github.com/mvp/uhubctl"
3BUGTRACKER = "https://github.com/mvp/uhubctl/issues"
4DEPENDS = "libusb1"
5
6LICENSE = "GPL-2.0-only"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
9SRCREV = "20276ad5ced147d018e2b3fccedabd94597aa25e"
10SRC_URI = "git://github.com/mvp/${BPN};branch=master;protocol=https"
11S = "${WORKDIR}/git"
12
13# uhubctl gets its program version from "git describe". As we use the source
14# archive do reduce download size replace the call with our hardcoded version.
15do_configure:append() {
16    sed -i "s/^\(GIT_VERSION :=\).*$/\1 ${PV}/g" ${S}/Makefile
17}
18
19do_install () {
20    oe_runmake install DESTDIR=${D}
21}
22