1SUMMARY = "Synergy - control multiple computers with one keyboard and mouse"
2HOMEPAGE = "http://synergy-project.org"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=54c1fc8d8bb6776ae501acfb1585e9d6"
4LICENSE = "GPL-2.0-with-OpenSSL-exception"
5SECTION = "x11/utils"
6
7DEPENDS = "virtual/libx11 libxtst libxinerama curl openssl"
8
9# depends on virtual/libx11
10REQUIRED_DISTRO_FEATURES = "x11"
11
12SRC_URI = "git://github.com/symless/synergy-core;protocol=https;nobranch=1"
13
14# Version 1.10.1-stable
15SRCREV ?= "1b4c076127687aceac931d269e898beaac1cad9f"
16PV = "1.10.1+git${SRCPV}"
17
18S = "${WORKDIR}/git"
19
20inherit cmake features_check
21
22EXTRA_OECMAKE += "-DSYNERGY_BUILD_LEGACY_GUI=OFF"
23
24FILES_${PN} += "${datadir}/icons/hicolor"
25