1SUMMARY = "Easy to use CLI and C library for communicating with Microsemi's Switchtec management interface"
2HOMEPAGE = "https://github.com/Microsemi/switchtec-user"
3SECTION = "console/utils"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3d6b07c89629cff2990d2e8e1f4c2382"
6
7DEPENDS = "ncurses openssl"
8
9SRCREV = "e7c351c6c722336b3c79b79cd002c7c2986eefb0"
10SRC_URI = "git://github.com/Microsemi/switchtec-user.git;protocol=https;branch=master"
11SRC_URI[sha256sum] = "a715e46d8498418dbb8a2519318ba0714ee148151d7e4a7fa5e27770a2f6888f"
12
13S = "${WORKDIR}/git"
14
15inherit autotools-brokensep pkgconfig
16
17EXTRA_OEMAKE = "DESTDIR='${D}' PREFIX='${prefix}' LDCONFIG='true' LIBDIR='${D}${libdir}'"
18
19do_install () {
20     oe_runmake install
21}
22