1SUMMARY = "This is the set of GNU shar utilities."
2HOMEPAGE = "http://www.gnu.org/software/sharutils/"
3SECTION = "console/utils"
4LICENSE="GPLv3+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7inherit gettext autotools
8
9SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
10           file://0001-Fix-build-with-clang.patch \
11           file://CVE-2018-1000097.patch \
12           file://0001-Fix-build-with-recent-gettext.patch \
13           "
14SRC_URI[md5sum] = "32a51b23e25ad5e6af4b89f228be1800"
15SRC_URI[sha256sum] = "ee336e68549664e7a19b117adf02edfdeac6307f22e5ba78baca457116914637"
16
17do_install_append() {
18    if [ -e ${D}${libdir}/charset.alias ]
19    then
20        rm -rf ${D}${libdir}/charset.alias
21        rmdir --ignore-fail-on-non-empty ${D}${libdir}
22    fi
23}
24
25BBCLASSEXTEND = "native nativesdk"
26